Mint Host - Email delivery failure on SG Shared Hosting – Incident details

Email delivery failure on SG Shared Hosting

Resolved
Operational
Started almost 2 years agoLasted 25 minutes
Updates
  • Resolved
    Resolved

    Great news. The team just confirmed that the incident is now fixed and everything is operational.

  • Identified
    Identified

    We have found what is causing the email delivery issue. Our engineers are currently working on that and hope to get a solved notice anytime soon.

    We are very thankful to our clients who are patiently waiting and supporting us to solve this temporary problem. Also special thanks to the clients who reported the issue with in-depth explanations.

  • Investigating
    Investigating

    We got a report that our Singapore shared hosting users are facing email delivery from cPanel. We are currently investigating the issue and hope to be solved soon.